PHPスクレイピングライブラリ「Goutte」インストール時にParse errorが出たときの対処法 | 東京都世田谷区 ホームページ制作 [k]id

PHPスクレイピングライブラリ「Goutte」インストール時にParse errorが出たときの対処法

Category PHP Update 2015.06.08

twitterfacebookgoogle+はてなブックマークPocketであとで読むfeedlyで購読

Goutte(グット)とは?

外部WEB上の情報の必要な部分を取得できるライブラリです。

Goutteインストール時にエラー

Goutteインストール時に下記のエラーが出現

git

Parse error: syntax error, unexpected '[', expecting ')' in...

配布元のgitを閲覧したところ

Requirements
Goutte depends on PHP 5.4+ and Guzzle 4+.

の記述があり
現行のGoutteはPHP 5.4以上で動作とのこと。

同様のエラーが出てしまった方へご参考まで。。

ページトップへ
kid