TinyMCEのプラグイン「template」がIE6だと使えない | 東京都世田谷区 ホームページ制作 [k]id

TinyMCEのプラグイン「template」がIE6だと使えない

Category Ajax,JavaScript,WEB Tips Update 2010.02.15

twitterfacebookgoogle+はてなブックマークPocketであとで読むfeedlyで購読

TinyMCEでテンプレート機能を使う時はプラグインのtemplateを使用するとおもうのですが、
何故か最新バージョンだとIE6でテンプレートが読み込まれず、選択できなくなってしまう。

TinyMCEのデフォルトのexamplesには外部JSを作り

// Drop lists for link/image/media/template dialogs
template_external_list_url : "lists/template_list.js",

上記のように設定すると書いてありますが、
どうもIE6がこのJSを読みに行っていないよう。。

そこでリストを外部JSにせずに、
直接下記のように記述することで回避できるようです。

template_templates : [
{title : "タイトル1",src : "テンプレート.htm",description : "説明"},
{title : "タイトル2",src : "テンプレート.htm",description : "説明"},
],
ページトップへ